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Librarian

Librarian is a drag and drop-compatible application for storing and retrieving
any type of data. It can be used with any application that supports drag and
drop (or copy and paste). You can create an unlimited number of libraries,
each of which can hold hundreds of items.

In particular, Librarian can be used with the following Microspot products:

¥ PhotoFix - to hold images, quickly and easily catalog photo CDs etc.

¥ 3D World - to hold clip art, textures, colors, 3DMFs and sounds etc.

¥ MacDraft - to hold PICT images of furniture, architectural and electrical 
components etc.
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GETTING STARTED

The Librarian application will have been installed on your Macintosh during the installation 
process. Double-click on its icon to launch it:

If a there is a Þle named Default Library in the same folder as the Librarian application, the 
Default Library will be opened. Otherwise, the following dialog will display:

¥ New Catalog: Choose to create a new Librarian catalog. A standard dialog will display. 
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Specify a name for, and location to save, the new catalog and click Save. A new, empty 
library will then display to the left of your screen:

¥ Open Catalog: Choose to open an existing catalog. A standard Open dialog will display for 
you to select the catalog to open.

¥ Quit Librarian: Choose to quit the Librarian application without opening a catalog or creat-
ing a new catalog.

¥ Cancel: Choose to cancel the dialog and remain in the Librarian application without open-
ing a catalog or creating a new catalog.

◆ Storing Data

You can drag and drop MacDraft, PhotoFix, 3DMF, PICT, QuickTime movie and sound Þles, 
and various other image format Þles into a library. An alias of the selected Þle will be stored.
L-4



    
You can also drag objects/groups of objects from MacDraft, PhotoFix, 3D World and any other 
drag and drop-compatible applications, and drop them into library Þles:

Data can also be cut or copied from an application and then pasted into the library.

Librarian will display a preview of each item unless there is insufÞcient memory to create one. 
If Librarian recognizes the data type, a standard data type icon will display. If Librarian does 
not recognize the data type, an unknown data type icon will display.

Important: If you drop a Þle into a library or use the Add File or Add Folder options, Librarian 
will not import the data, but rather keeps an alias of the Þle. Do not delete the original Þle as 
the data will be lost. When dragging a real object, like a PICT from the Scrapbook, TEXT from 
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SimpleText or a 3DMF object from 3D World, Librarian saves a copy of the actual data in the 
library Þle.

◆ Retrieving Data

There are two ways to retrieve data from a library. You can either drag and drop an item 
directly into an application that supports drag and drop, or select an item, cut or copy it, then 
paste it into your document Þle. Multiple items can be dragged out of a library Þle at the same 
time. Single items can be cut or copied.

When dragging multiple items out of a library Þle, you may not be able to see all of the 
selected items. In this case, the outline that is dragged over your application window will have 
plus (+) signs above and below it to show that additional items are being dragged:
L-6



    
◆ Naming Items

By default, items are displayed in alphabetical order. Unnamed items will display as untitled 
when placed in a library. To name or rename an item, select its icon and enter a name in the 
Item Name Þeld at the bottom of the library window:

When you enter a name and press the Enter or Return key, the item will be updated to reßect its 
new name, and will remain selected.
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You may also update an item by entering a name then selecting another object, or clicking on 
an empty space in the library. 

◆ Selecting Library Items

When you click on an item that is stored in a library, it will be outlined with a black rectangle 
to show it is selected:

To individually select additional items, hold down the Command key and click on the desired 
items.

To select several consecutive items, click on the Þrst item, hold down the Shift key and click on 
the last item you want to select. Both items and all items between them will be selected.

To select every item in a library Þle, choose Select All from the Edit Menu.

To deselect individual items, hold down the Command or Shift key and click on selected items.

To select none, hold down the Shift key and the Select All menu item changes to Select None. 
Choose Select None, or click on an empty area of the library or the space between library 
items, to deselect all the items in the library.

Use the arrow keys to move quickly and easily through the library in any direction.
L-8



       
◆ Searching For Items

To search for a library item, enter its name in the Find Item Þeld at the bottom of the library 
document window:

The Þrst item that matches the name will be selected. Note that Librarian searches for names 
that match or start with the name you enter. 

The Find command in the File menu can also be used to search for library items.

◆ Sounds

To listen to a sound stored in a library, double-click on the soundÕs icon. If a sound has been 
attached to a 3DMF, double-click on the 3DMF icon to play the sound. Multiple sounds can be 
played at the same time. To stop a sound from playing, press Command - period.
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MENUS

◆ File Menu

New (Command-N)

Select New to open a new library. The standard dialog will display, allowing you to enter a 
name for the new library and specify a location to save it.

Open (Command-O)

Select Open to open an existing library. A standard dialog will display for you to select the Þle 
to open. The position and size of the library and the view it displays will be the same as the last 
time the library Þle was open.

Close (Command-W) / Close All (Command-Option-W)

Select Close to close the current library. The Librarian Auto Save feature saves the library Þle 
whenever you add data, so you do not need to save any changes.
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Hold down the Option key and this menu item changes to Close All. Select this to close all 
open libraries.

Add File

Use the Add File menu item to add an alias of a selected Þle, rather than the actual Þle data, to 
the library.

When you choose Add File, a standard dialog will display so that you can select a Þle:

Click Open after you have made a selection to place the Þle alias in the library:

Important: As library Þles do not store the actual Þle data, do not delete the original Þle or the 
data will be lost.
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Add Folder

Use the Add Folder option to add aliases of all Þles within a folder, and its sub-folders, to a 
library. (This feature can be used to quickly and easily catalog images on Photo CDs.)

When you choose Add Folder, a standard dialog will display so that you can select a folder:

Click the ÔSelect folder name Ôbutton once you have made a selection. If there are several Þles 
in the folder, a dialog will display progress information as the contents of the folder are pro-
cessed. Click Stop at any time to stop the processing of the folder contents.

The Þles in the folder will have their aliases added to the library:
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The contents of folders can also be added to a library by dragging the folder into the library. 
The contents will be processed, and aliases to the Þles in the folder added to the library, as 
above.

If the contents of a folder are added to a library using the Add Folder command, but the process 
is stopped part way through, only some of the items will have been added to the library. If the 
same folder is then added again, items will not be duplicated in the library, but the remaining 
items, not added to the library previously, will now be added.

Find (Command-F)

Use the Find command to search for library items.

Choose Find. The Find dialog displays:
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In the Þrst popup menu, select the name of the current library, or choose to search all open 
libraries:

In the second popup menu, choose one of the following:

¥ selected or unselected: to search all library items

¥ selected: to search only those items that are currently selected (to reduce the current selec-
tion)

¥ unselected: to search only those items that are currently not selected (to add to the current 
selection)

In the third popup menu, choose the type of Þle to search for:
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Enter data in the Name, Key Words, Comments and Size Þelds to further qualify your search, if 
required.

Click Find. The speciÞed libraries will be searched for Þles matching your search criteria. Any 
Þles found will be selected.

Open Selected Items

Select an item or items in the library and choose Open Selected Items. The item(s) will be 
opened in the appropriate application(s).

Library items can also be opened by double-clicking on the item in the library, or by dragging 
the library item onto a suitable application.

Show Original File (Command-R)

Use the Show Original File option to locate the original Þle relating to an alias in a library.

Select a library item and choose Show Original File. The Finder window containing the origi-
nal Þle will open, with the original Þle selected within it.

Export File

The Export File option is used to export any Þle in a graphic format as another Þle type. Export 
File will only be available if you have QuickTime 3.0 running.

Select a library item that is in graphic Þle format and choose Export File from the File menu. 
The Export File dialog displays:
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Choose a location to save the Þle and select the Þle format for the exported Þle from the Export 
image as popup menu. The options available in this menu will be determined by the translation 
options available to QuickTime 3.0. By default the Þle will be given the same name as the orig-
inal Þle, with an extension relating to the Þle type chosen.

Update Library

Use the Update Library option to update any library items that have been revised.

Select the option from the menu. The library contents will be reviewed and any changes, such 
as the preview icon for a Þle alias, will be updated.

Select Missing Files

Use the Select Missing Files option to determine if any original Þles are missing.

Select the option from the menu. The library contents will be reviewed to check that original 
Þles can be found for each Þle alias in the library. If any original Þles cannot be found, the 
aliases in the library will be highlighted.
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Page Setup

Select Page Setup to access the Page Setup dialog.

Print (Command-P)

Select Print to print the library contents.

The print produced will be of the entire library contents, Þtted as best as possible to the page 
size, regardless of the current view of the library.

Quit (Command-Q)

Choose Quit to exit the Librarian application. All open library Þles will be closed.

◆ Edit Menu

Undo (Command-Z)

Actions performed within the Librarian application cannot be undone, so the Undo option will 
be grayed out. 

Cut (Command-X)

The Cut option removes a selected item from a library Þle and places it on the Clipboard until it 
is replaced by using the Cut or Copy option again.
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Copy (Command-C)

The Copy option places a copy of a selected item on the Clipboard until it is replaced by using 
the Cut or Copy option again.

Paste (Command-V)

Select Paste to place an item from the Clipboard into the current library.

Clear (Command-Delete)

Select Clear to remove an item from a library without placing it on the Clipboard. Note that an 
alert will display when you select this option:

To bypass the alert, hold down the Option key when you select the Clear option.

Select All (Command-A)/Select None (Command-Shift-A)

Use the Select All command to select all of the items in the current library.

Hold down the Shift key and this menu item changes to Select None. Use this menu item to 
deselect all the items in the library.
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◆ View Menu

Icons

Select Icons from the View menu to display icon size previews (32 x 32 pixels) of a libraryÕs 
contents. Although the itemsÕ names will not be displayed, you may still search for items by 
name using the Find Item Þeld at the bottom of the library window.

Thumbnails

Choose Thumbnails from the View menu to display thumbnail previews (64 x 64 pixels) of a 
libraryÕs contents. The library itemsÕ names will also be displayed:
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The Library document window may be slightly resized to display an exact number of thumb-
nails.

Show Item Info/Hide Item Info

Select Show Item Info to display information about the library items next to the icon or thumb-
nail preview. In the Thumbnails view, an additional comments Þeld can also be seen.
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When the item information is displayed, the menu item changes to Hide Item Info. Select this 
option if you do not wish to display the item information in the library window.

Show Info Palette (Command-I)/Hide Info Palette (Command-I)

Choose Show Info Palette to display a palette containing information about the currently 
selected library item. In addition to the standard item information, the Info Palette also has a 
Key Words Þeld. Use this to enter key words about an item, these can then be used in searches.
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When the Info Palette is displayed, the menu item changes to Hide Info Palette. Choose this 
option to close the Info Palette.

◆ Sort Menu

Use the Þrst Þve options in the Sort menu to sort the items in the current library.

By Item Name

Items are displayed in alphabetical order according to the item name.

Note: Item Name and File Name will not necessarily be the same. Item Name refers to the 
name of the item in the library, and this can be changed in the library. File Name relates to the 
name of the original Þle, if the library item is an alias. In this case the File Name cannot be 
changed in the library.
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By File Name

Items are displayed in alphabetical order according to the Þle name. (See note above.)

By Size

Items are displayed according to the Þle size, with the largest Þle Þrst.

By Kind

Items are sorted according to the Þle type.

By Date

Items are displayed according to the date the Þle was last modiÞed, with the most recent modi-
Þcation date Þrst.

◆ Help Menu

Librarian includes Balloon Help, accessed via the Help menu:

To use Balloon Help, select Show Balloons from the Help menu. As you move the cursor over 
the document or menu items, help messages will display about those items.

When Balloon Help is turned on, the menu item changes to Hide Balloons. Select this option to 
turn Balloon Help off.
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